Registrarse Gratis

¡Únase para Aprender y Compartir!

¿como instalar un led que parpadee en los parlantes?

15/4/2017 04:25PM
hola
tengo un circuito TDA2822 alimentado con una fuente de 5VCC
1º opcion : que en la salida de audio si le conecto el led este parpadea bien

2º opción : pero que cuando enchufo el cable de los parlantes a las fichas de entrada
de los parlantes el led recien parpadea cuando el volumen general
de la pc lo subo a mas de la mital del total

¿que tengo que hacer para que parpadee como en la 1º opción?
Gracias.
¿Sabes la respuesta?Responder
15/4/2017 04:54PM
tiene que poner un circuito entre la salida y el o los leds para que trabajen independientemente de la conexion con el parlante
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 05:00PM
claro asi es la cosa
el led no tiene que estar en contacto con el parlante

Ahora Victor E
Pasame el diagrama de ese circuito
Gracias
15/4/2017 05:03PM

[/b]
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 05:34PM
hola Victor E
ok ,pero algo no entendí
¿con que voltajes puede alimentarse este circuito?

y ¿ puede este circuito alimentarse con los voltios del sonido que salen del volumen de la pc? (de unos 2VCC a 3 VCC)
15/4/2017 05:49PM
no ese circuito trabajacon 12 volts, la pc tiene esa tension.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 06:01PM
Hola Victor E
Mi fuente de alimentacion al amplificador TDA2822 es de 5VCC
Ademas necesito un circuito para un solo led
Gracias
15/4/2017 06:07PM
y ese es el mas simple que hay.voy a ver si consigo otro
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 06:25PM
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 08:25PM
Gracias Victor E

1º :
4k7 ohms ¿que valor de resistencia es esta ?
¿serán 47k ?

--------------------------------------------------------------------------
2º: Los 5 VCC de mi fuente son los que alimentan el amplificador TDA2822
Ahora la salida de audio con el voltaje de la pc al maximo no supera los 3 VCA

¿Como encaja esta situación en el diagrama de los 5V en la entrada?

Smile Desde ya muchisimas gracias
15/4/2017 08:34PM
los 5 volts de cc viene de la pc y alimenta el integrado de audio,esa tension debe ir a la resistencia de 390 ohms.la salida de audio no tiene nada que ver con la alimentacion de los circuitos,excepto la conexion a la resistencia de 4700 ohm o 4k7 o 4,7kohm,que va a la base del transistor c945
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 08:57PM
No lo estoy entendiendo porque siento que no entendistes mi pregunta

1º Este circuito con el Transistor C945 supuestamente por lo que habia consultado en mi pregunta ¿era para que?
Para que el led rojo de 5 mm que yo quiero instalar en mi cajita acustica de los parlantes ,parpadee cuando haya volumen de sonido en la pc
Ademas , el TDA2822 esta alimentado no por la pc , lo alimento con un trafo rectificado con salida de 5VCC
Ahora este circuito que proponés ¿no va acaso alimentado con la salida de audio que entra en los parlantes ?
Por eso te decia en otro mensaje que el voltaje en la entrada a parlantes no supera los 3 VCA (que sopongo que esos 2 cables son los que alimentarán y regularán el funcionamiento del circuito con el C945 ,haciendo parpadear el led con mas intensidad a medidad que el volumen aumente
Smile
15/4/2017 09:03PM
que cabeza dura, este circuito tiene dos alimentaciones, 5 volts que es independiente de la salida de audio y alimenta el led y el transistor aislador, a su vez el transistor recibe en la base la señal de audio del parlante para producir el parpadeo en el led de acuerdo a las variaciones de la señal de audio.por eso le dije que la resistencia de 390 ohm debe ir a los 5 volts que alimenta el circuito integrado de audio o sea a la fuente de 5 volts.se entiende?
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 09:15PM
te estaba escribiendo justo cuando me respondistes, diciendote
que empezaba a entenderlo , claro que me di que tiene 2 alimentaciones , como yo habia pedido para hacer el parpadeo con los cables de audio al parlante , me quede medio fuera de lugar
Claro que asi ahora comprendo este circuito con el C945

Entonces asi tengo que llevar otro cable desde el amplificador con los 5VCC al parlante
¿los 390 ohms? ¿los calculastes vos para bajar los 5 VCC de mi fuente a los 3 VCA que te habia dicho que habian el los cables del audio al parlante cuando el volumen estaba al maximo?
Gracias Smile
15/4/2017 09:20PM
la alimentacion de un circuito no tiene nada que ver con la señal de audio,los circuitos de transistores no se alimentan con ca o sea tension alterna,todos los circuitos electronicos se alimentan con cc o tension continua,5v, 12v, 24 v etc.la señal de audio que ud mide,2 o 3 volts es la que entrega el amplificador y jamas en ningun equipo se usa para alimentar un circuito.en este caso va a la base del transistor como señal de audio para hacer que el led parpadee al ritmo de la musica, o lo que se amplifique.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 09:28PM
entendí Victor E

yo no dije lo contrario , primero de todo te agradezco el diagrama Y el lunes comprare ese C945 si lo consigo

Lo que pasó es que el principio mi idea era colocarle el led a los 2 cables del audio que van al parlante y no me funcionó bien eso , por eso pregunté en el foro
¿el transistor C945 va a necesitar disipador?
15/4/2017 09:30PM
no creo, no es mucha potencia el amplificador.son 2 watts,si mal no recuerdo
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
15/4/2017 09:43PM
claro y tambien entendi el porqué de los 390 omhs en la entrada al led , es para que no se queme el led con los 5VCC
quedarian unos valores mas o menos asi con los 390 ohms


Y bueno no mas que felicitarte y agradecerte
pero recien el lunes quizas consiga el C495
Smile
16/4/2017 02:36PM
Buen dia Victor E
Me han cometado que cualquier NPN me servirá
yo tengo un TIP 31 que es un NPN
¿Puedo reemplazar el C945 con este TIP 31?
y si podría ,¿tambien puedo dejarle los mismos valores en ohmios a las 2 resistencias que lleva el circuito?
Saludos Smile
16/4/2017 03:46PM
si, no hay problemas.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 03:55PM
hola , quizas sea un poco pesado
pero el negativo del led ¿entra en el emitter o en el collector del C945?
¿Y en el TIP31 el negativo del led entra en el emitter o en el collector ?
Smile
16/4/2017 03:58PM
el catodo del led va al colector del transistor, sea el c945 o el tip31,debe respetar el circuito, el emisor va a masa o el negativo de la fuente.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 04:15PM
perfecto ,entonces

Como este tip31 lo usé ya una vez pero casi nada
¿como comprabarias vos con un tester si esta sano o no sirve?
Gracias
16/4/2017 04:17PM
midiendo con el ohmetro que no haya cortos entre pines.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 04:19PM
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 04:20PM
perfecto ,entonces

Como este tip31 lo usé ya una vez pero casi nada
¿como comprabarias vos con un tester si esta sano o no sirve?
Gracias
16/4/2017 04:22PM
mire el video,ahi el profesor enseña como medir transistores con el tester o multimetro.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 04:40PM
Muy bien explicado

En mi TIP 31
de la base al collector mido 658 ohms y al emitter 659 ohms
Creo que esta sano
16/4/2017 04:45PM
siempre despues de hacer una medicion invertir las puntas.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 04:55PM
No me dijistes que tendria que pasar al invertir las puntas luego de una medicion

Hice esa inversion de las agujas del tester
y el resultado es 1 al collector y 1 al emitter
16/4/2017 05:02PM
para que te pase el video?siempre hay que hacer eso por si el transistor tiene fugas.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 05:21PM
Perdoná , sera porque vi la primera parte nomas

pero si hubiese fugas adonde a mi marca uno
habria en cambio algunos numeros
¿no es cierto?

Me causa la impresion que el TIP 31 deber de ser un NPN mucho mas potente que el C945
ya que este TIP 31 soporta 3 Amperes
16/4/2017 05:29PM
en este caso no va a consumir esa corriente,3 amper,solo lo que el led necesite para maximo brillo.ademas 3 amper es lo maximo que puede dar ese transistor,en la practica real se quemaría.en todos los transitores la corriente real que puede entregar es un 50% de lo que figura en la hoja de datos.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 05:43PM
hola victor
me referia a lo del tip31

por el hecho en si de que era mas potente no por el hecho de que quemase al led

Cuando dijistes de invertir las agujas
puse la aguja roja en el base y la negra en el coolecto y dio 658 ohms
al invertir las agujas ¿te referías a poner la aguja roja en
el collector y la negra en la base ?
ahi me marcó 1
16/4/2017 06:16PM
esta bien el transistor.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 06:19PM
hola
Ya empezé a construir el proyecto
Smile
16/4/2017 06:22PM
tenia que haber terminado,porque es muy simple.cuidado con las conexiones
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
16/4/2017 06:37PM
si si , facil cuando ya lo sabe
Aca tengo de renovar varias cosas en la caja tambien
hacer la plaqueta , todo es muy artesanal lo mio
Dejame hacerlo y te comentaré como queda
gracias Victor E Smile
17/4/2017 08:19PM
Victor E
¿vistes que en no es facil?

Aqui el circuito con el C945
facil si , pero no se enciende el led y ni todo es chisporreo de sonido , añl desenchufar el circuito de la fuente de los 5Vcc 300 mAh ,la cosa se normalizó
Aclaro que esta fuente alimenta tambien el circuito del amplificador TDA 2822


Ultima edición por coldd el , editado 1 vez
17/4/2017 08:27PM
con una fuente de 300ma alimenta el integrado de sonido?medio pobre su fuente.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
17/4/2017 08:28PM
justamente tambien a mi me dio esa impresion sera que por esa razon sucedio lo que sucedio?
17/4/2017 08:31PM
si, el integrado de audio consume bastante corriente depende del volumen,mas el otro circuito...
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
17/4/2017 08:37PM
lo que hice ahora es desconectar el TDA2822 de la fuente de 5 Vcc 300 mAh y dejar conectado solo el C945 y el led rojo no se enciende , supongo que seria porque no hay sonido en volumen
El tda3822 no me acuerdo bien pero funciona desd e 3V a 17V
17/4/2017 08:43PM
el led se tiene que encender solo cuando haya sonido en la base del transistor
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
17/4/2017 08:48PM
claro , entonces el proximo paso es cambiar el trafo de 300 mAh rectificado por otro de 1A

¿que te parece?
17/4/2017 08:50PM
y si es mas amperaje mejor.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
17/4/2017 10:29PM
hola Victor
consegui un trafo de 0.800 mAh y que rectificado
da 7,78 o 7,84 VCC
le quiero poner el regulador 7805 y como est necesit en su entrada 3 voltios mas que los 5V en su salida o sea 8 VCC
Te consulto que pasaría si mi rectificacion entrega 7,78 VCC
Saludos
17/4/2017 10:45PM
puede colocar el 7805 por las dudas.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
18/4/2017 01:38AM
Victor
escuchame una cosa
¿cuantos mAh puede necesitar el C945 para ese led de 5 mm ?
poco y nada pregunto porque sospecho
que no es un problema del amperaje

Decime: de la base del C945 con la R47 Komhs
esta va al supongo al positivo del parlante
Está todo bien hecho
Confused
Me extraña nomás que por unos como mucho 17 mAh que gaste con el led la fuente de sus 300 mAh que tiene
que inutiizable el TDA2822 y el led
Smile
18/4/2017 06:25PM
hola Victor E
Por fin se solucionó con esta otra fuente de 800 mAh
Lo unico que no me queda bien es que el volumen tiene que subir a un 15% del total para el led empieze a parpadear
¿hay que cambiarle esa R de 47 kohms
que va de la base del C945 al parlante por otra?
Smile
18/4/2017 06:46PM
la resistencia del circuito no es de 47k o 47000 ohms, es de 4k7 o 4700 ohms.
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
18/4/2017 06:53PM
ahhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhh
Very Happy
Entonces la voy a cambiar
gracias
18/4/2017 07:57PM
hola ,
puse los 4700 ohms
preo al fallar el encendido del led, medi con el tester ,el C945 instalado en el circuirto ,poniendo la aguja del com en la base del C945 y la aguja roja en el emitter y marca unos 1900 ohms
Lo demas marca normal
¿esta arruinado este C945? Smile
18/4/2017 07:59PM
porque no usa el tip 31 que soporta mas corriente?
Victor E 21.219K
ASISTIÓ A LA SOLUCIÓN
18/4/2017 08:06PM
no
no uso el tip31
estoy usando el C945
Ahora desoldé las 3 patas del C945
y las mediciones del C945 se normalizaron.

Resulta que el led no enciende ahora que puse la Rde 4700 ohms
peo con la de 47000 ohms encendia , aunque el volumen debia estar un 15 % alto
18/4/2017 08:28PM
si si
esta bien
Las marcaciones sin correctas
lo que esta sucediendo que no va
es que el parpadeo comienza cuando el volumen
llega a un 30 % del volumen de alto
ademas a un 30 % es raro que se use ya que
suena bastante fuerte
¿que harias vos para que el parpadeo se efectue
habiendo tambien volumen bajo tambien?
18/4/2017 08:34PM
¿ves el volumen en Altavoces y HDCap?
recien en ese volumen empieza a parpadear el led
el volumen asi ya está bastante alto.
20/4/2017 02:15PM
hola Victor E
O sea que vos decis que es ese C945 el la causa esos
ruidos opacos que no permite escuchar bien los sonidos
Yo quise segui el circuito simple que me enviastes
¿como sigo ahora?

¿le pongo el TIP 31 y saco el C945?
Saludos
20/4/2017 02:25PM
Por mi parte pienso que tambien es posible que ese sonido vicioso
se deba a que el circuito con la alimentacion de 5VCC este colocado muy cerca de los parlantes
20/4/2017 02:39PM
Y mas que pensarlo , recien lo he comprobado .
Al desconectar el circuito desde los 5VCC ya se solucionaron esos molestos ruidos
¿y entonces Victor E como seguimos?
Smile
22/4/2017 07:06PM
Hola Victor E
te aviso que coloqué ese TIP31
y el sonido ese como de un becerro mullando
* (no sé si se dice asi exactamente :mullar)
al conectar el circuto del vumetro
es el mismo que con el C945 , muy molesto
de paso ademas bajé un poco el valor de esa R 4700 ohms
para que el led ya empieze a parpadear desde un volumen
bajo poniendo una R de 2200
Eso salió bien, el parpadeo está bien y funciona
pero ese ruido de un cordero mullando
es muy molesto
Decime que pensás? Smile
22/4/2017 09:46PM
Victor E
Decime ahora como se arregla esa molesta interferencia
27/4/2017 07:35PM
Hola victor
lo de las interferencis no se porque,
pero igualmente ese vumetro que me enviaste empieza a parpadear
recien al 25% del volumen total y eso que lo solucioné un poco reemplazando con una R 2200 ohms a la de 4700 omhs
Saludos
27/4/2017 07:54PM
Si estas alimentando el led con 5v prueba con una resistencia de 1k ohm menos, dependiendo si el led es normal o de alto brillo. Saludos
comentario
¿Sabes la respuesta?Responder

Bienvenido/a!

YoReparo es la mayor comunidad sobre tecnología. Colaboramos y compartimos información para solucionar todo tipo de problemas técnicos.

Para participar solo hace falta que te registres gratis aquí

Todos los Foros