Tienda | Foros | Blogs | EN
 

Arduino y display 128X64

Seguir
Buenas tardes comunidad,  a ver si me pueden ayudar con este display ( http://www.alldatasheet.com/datasheet-pdf/pdf/90428/ETC/WG12864A.html ). Quisiera conectar este display a arduino mega,  pero...  Estoy un poco desorientado con  cuales son los pines que se conectarian a arduino para poder controlarlo,  lo q es alimentacion,  con el potenciómetro y demas,  ya lo conecté.  Me faltan lo que serían los de control para poder enviar las órdenes al micro del display. 
Si alguien puede ayudarme,  desde ya mil gracias.  Saludos!


  • hace 2 años

    Avatar de Armando almarales

    Chequeaste el contraste? revisa que voltaje le llega al pin del contraste

1 Solución propuesta

SOLUCIÓN ACEPTADA
Hola Arycar!

Todo depende de la librería que estés usando. En el datasheet dice que ese modulo GLCD lleva incorporado un circuito KS0108, eso ya nos da una idea de la compatibilidad con las librerías típicas de arduino para GLCD que se consiguen en internet.

Te coloco una librería muy detallada que conseguí para módulos basados en KS0108
https://playground.arduino.cc/Code/GLCDks0108

Para el conexionado, todo depende de como programes sus I/O, no es un conexionado fijo, tu lo adaptas a como te sea mas facil cablearlo editando las siguientes líneas y colocandolas preferiblemente antes de la función setup(). Adicional a eso, recuerda colocarlas como salidas dentro del Setup(). #define glcdData0Pin 8
#define glcdData1Pin 9
#define glcdData2Pin 10
#define glcdData3Pin 11
#define glcdData4Pin 4
#define glcdData5Pin 5
#define glcdData6Pin 6
#define glcdData7Pin 7
#define glcdCSEL1 14 (Analog pin 0)
#define glcdCSEL2 15 (Analog pin 1)
#define glcdRW 16 (Analog pin 2)
#define glcdDI 17 (Analog pin 3)
#define glcdEN 18 (Analog pin 4)

Comenta cualquier duda.

Que estés bien, Feliz Noche!
  • hace 2 años

    Avatar de AryCar

    Hola estimado, muchas gracias por tu ayuda y disculpa la demora en exponder. Esa libreria que dejaste, ya la descargue, tambien conseguí esquema de conexionado, pero me paso algo muy extraño.... Una vez compilado, no da errores, pero lo cargo a la placa y esta no presenta nada en dicho display. Ya me meteré nuevamente al dia con eso, venía con mucho trabajo ultimamente. Gracias y saludos!